VMware genera multiples interfaces de red, eth1, eth2, eth3… WTF ?

8 09 2012

Me encontré con un problema con VMware al mover una maquina guest virtual de una computadora real (host) a otra. Al descargar una maquina virtual de Internet, la levante en VMware Player y me encontré que al listar las interfaces de red en la maquina guest (que a efectos de este evento, corria Linux), me listaba 2 interfaces:

  • lo (interfaz de loopback que todas las maquinas tienen)
  • eth3 (interfaz ethernet con la cual me queria conectar a la red en la que estaba)

Al momento de hacer las pruebas, tenia configurada la interfaz de red virtual desde el Host en modo Bridge, no me gusta mucho el NAT en maquinas virtuales a menos que lo necesite por algún motivo particular.

Luego de configurar la interfaz en la maquina guest, la red funciona ok, tengo trafico, tengo internet.. etc, etc. Todo bien.
Es en este momento que me llama la atención de porque la interfaz en la maquina guest, recién encendida, la lista como “eth3” y no como “eth0” como siempre lo hace en un sistema linux. No tengo mas interfaces configuradas o conectadas, por lo que no debería de ser asi.

Luego de buscar un rato, me encuentro con este post en el foro de LinuxQuestions.Org, que parece que hay un problema moviendo una maquina virtual de una computadora a otra. Cada instancia de VMware genera una dirección MAC para conectarle a la virtual guest, y a menos que tengamos vmware configurado igual en ambas computadoras host, esa dirección MAC es diferente en cada instancia.

Por lo que al mover una virtual de una pc a otra, y encendiéndola claro, el sistema deja registro de la interfaz de red que le fue conectada, identificándola con su dirección MAC, por lo que va a tener una lista interna de todas las interfaces que le fueron conectadas, cada una con una denominación independiente. Por eso “eth3”, para el sistema, ya se le habían conectado 3 interfaces ethernet previamente, con MACs diferentes.

Funcionalmente no hay problema, como dije antes, la red funciona bien. Pero para quienes somos mas quisquillosos, el archivo que tenemos que modificar esta en:

/etc/udev/rules/

Lo que tenemos que buscar es un archivo con extencion “xxx.rule” que tenga en el nombre la palabra “net“.

Dentro de ese archivo encontraran la lista de las múltiples direcciones MAC que fueron conectadas al sistema, y su denominación especifica (eth0, eth1, wlan0, wlan1, ath0, ath1, etc).
Todo lo que tienen que hacer es eliminar las que no existan mas o cambiar el nombre de la que quieran.

Recuerden hacer un respaldo del archivo antes como siempre debemos hacer antes de modificar un archivo del sistema.

cp /etc/udev/rules/archivo-ejemplo-net.rule /etc/udev/rules/archivo-ejemplo-net.bak

Bien, espero que a alguien le sirva, yo en particular aprendí otra vez algo nuevo e interesante! 😀

Saludos tuxeros

Link al enlace original: http://www.linuxquestions.org/questions/debian-26/eth0-device-not-found-why-689751/

Anuncios




Dos sistemas operativos en 1 sola computadora

9 11 2011

Como usar 2 teclados y 2 mouses en la misma computadora fisica. Se puede usar un segundo monitor, y un segundo juego de teclado/mouse para una maquina virtual, con lo que tendriamos 2 computadoras en 1 !!!

http://blog.rahady.com/2009/10/running-2-oses-with-separate-mice-and-keyboards





Moving a VirtualBox virtual machine from one coputer to another

11 06 2011

Ok, so today I encountered a relative simple problem.. and a bit dumb also..

Virtualization is supposed to make our lives a bit easier.. and Oracle (from my point of view) has failed to do so. I got a new box at my place, so as you all may guess, i tried to move all my vm’s to my brand new shinny box. As an open source padwan, i try to mantain all my software and knowledge.. guess.. YES, open source !

That’s why i chose VirtualBox for my virtual lab.

On to the issue.. i just copied (click ‘n’ drag or $cp -r via console.. its the same result) my vm’s and all their files to an USB HDD, and then, again to the new box. BTW, both boxes are running Ubuntu (10.10 and 11.04). I had installed different versions of VirtualBox, but since im going from an “old” version to the latest version.. i thought there would be no problems at all.. you all know backwards compatibility right ?

Ok, so i fire up VBox on the new.. box :P, create a new vm, and i choose “an existing virtual disk”. And to my surprise, it returns an UUID problem. Seems that it wont be able to read the .vdi file.

Not reading/searching the error message, i thought it was just a user owning issue. So i $chmod the files.. and tried again. Same error message: ns_error_invalid_arg (0x80070057).

So a bit of searching.. it seem that i should have RTFMFA (aka read the manual). The method to copy/move/backup is using the VBoxManage framework, the complete command is like this:

$VBoxManage clonevdi /path-to-original/vm.vdi /path-to-destination/vm2.vdi

Remember to use full path to the files !

This way VBoxManage changes the UUID to the one on the box you are trying to move the vm. And problem solved !

After that just create a new virtual machine and use the “existing virtual harddisk” from where you chose to store it.