Instalando Metasploit en Ubuntu 10.04

15 06 2010

Luego de instalar varios programitas en mi nueva distro, Ubuntu Lucid Lynx 10.04 LTS.. entre los cuales se encontraba la nueva version del metasploit framework..

Prosegui a probarlos para ver que todo funcionara como deberia funcionar.. pero! para variar con la vida diaria del linuxero nuevo… aparecieron errores..

A buscar por google… algunos foros.. luego de unas cuantas horas, logre encontrar lo que queria. Claro esta que esto sucede por no leer lo que debemos leer antes que nada.. los manuales.. documentacion del software.. etc.

El problema era al tratar de crear una nueva base de datos con el comando “db_create”, a lo que me saltaba el siguiente error:

msf> db_create
[-]
[-] Warning: The db_create command is deprecated, use db_connect instead.
[-]          The database and schema will be created automatically by
[-]          db_connect. If db_connect fails to create the database, create
[-]          it manually with your DBMS’s administration tools.
[-]
[*]    Usage: db_create <user:pass>@<host:port>/<database>
[*] Examples:
[*]        db_create user@metasploit3
[*]        db_create user:pass@192.168.0.2/metasploit3
[*]        db_create user:pass@192.168.0.2:1500/metasploit3

db_create [-] [-] Warning: The db_create command is deprecated, use db_connect instead.[-]          The database and schema will be created automatically by[-]          db_connect. If db_connect fails to create the database, create[-]          it manually with your DBMS’s administration tools.[-] [*]    Usage: db_create <user:pass>@<host:port>/<database>[*] Examples:[*]        db_create user@metasploit3[*]        db_create user:pass@192.168.0.2/metasploit3[*]        db_create user:pass@192.168.0.2:1500/metasploit3

Bueno, cuestion.. la solucion a esto era que no le habia dicho aun que driver tenia que usar para crear las bases de datos.. (sqlite3).

Leer el resto de esta entrada »